当前位置:首页 > 问答

波浪趋势自动画线指标

我来帮TA回答

求通达信自动画线公式

这个问题要参考绘图函数DRAWLINE的应用,举例如下:
DRAWLINE 绘制直线段
在图形上绘制直线段。
用法:DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)
当COND1条件满足时,在PRICE1位置画直线起点,当COND2条件满足时,在PRICE2位置画直线终点,EXPAND为延长类型。
例如: DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,1) 表示在创20天新高与创20天新低之间画直线并且向右延长。
由于你提供的信息有限,只能回答到这一步了,仅供参考。

三阴线平台自动画线公式指标

那些送什么指标送什么选股器的都靠不住,如果谁要十拿九稳的能选中好股票,谁还在这里回答问题啊,早偷偷一边儿赚钱去了。以后有什么公式不会写直接找我...

请高手中的高手,编写一个通达信的自动画线公式,(包括长期趋势,中短期趋势线)

{N:=75;P:=5;P1:=10; 参数范围1---100}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN,DOTLINE;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED,DOTLINE;
AA1:=REF(C,P1)=HHV(C,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN LINETHICK2;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED LINETHICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
突破:C>短压 OR C> 长压,NODRAW;
DRAWICON(突破 AND REF(突破,1)=0,L*0.99,1);
手动调节参数以达到最佳效果,一定要提防假突破。

趋势线预警的问题

在走势图或指标图上画线可帮助您更好地进行图形分析。通过选择菜单“查看 → 界面选项 → 画线工具条”或快捷键〖Shift〗+〖X〗可显示/隐藏画线工具条,可拖出工具条成为浮动的工具条窗口。
点击鼠标选择一种工具进行画线,画线一般采用鼠标拖动方式进行,移动鼠标到绘图区,在画线起点按下鼠标左键不放并拖动鼠标到终点位置,此时系统就会跟踪您移动鼠标的过程,自动提供一个反馈图形,有些画线还提供角度的提示(如画直线,速阻线,江恩线等)。当您觉得满意时,放开鼠标左键就可以在屏幕上画出该种线型。由于在绘制过程中有一个反馈过程,所以您可以轻易直观地画出满意的线条。
有的用户希望能够得到非常精确的画线及画线参数自定义,希望画线的起点与终点能与股票价格严格对应起来及使用自定义参数,这时你可以使用“画线设置”的功能来实现。方法是用鼠标右键点击此画线,然后在其右键菜单中选“画线设置”。(其中黄金分割线、江恩线、多通道线、波浪预测、百分比线、费氏时间线、费氏圆、多圆弧可独立调整画线参数,黄金分割、黄金分割A、黄金分割B、波浪预测、百分比线、标准差通道中的[画线设置]中可设置是否向左、右延长。)
画线完成以后,可用鼠标拖动画线的起点或终点,改变画线方向;还可以按住CTRL键,用鼠标拖动画线的定位点(选中画线后显示为小方块),系统的吸附功能能将此线上的小方块自动定位到该K线上的最高或最低点。
画线过程中如需多次重复使用同一种画线方式,可在工具条中先选定“保持画笔”功能,或者进入“查看->画线操作->保持画笔”选择它,使用时就无需每次都点击工具条。这种模式下,如果要做画线外的其他操作,则要先点击工具条中的小箭头按钮。
鼠标左键点击击画线,可看到画线起点和终点出现小方块,表示已选中该画线,此时按〖Delete〗键可删除它。也可在右键弹出菜单中选“删除”项删除。如果要删除所有的画线,请在画线工具条点击“删除所有画线”按钮。
鼠标右键点击击画线,在弹出菜单中选“颜色”可改变画线颜色,画线的默认颜色在“选项”的“外观设置”中进行设置。同时在工具条上也有快捷方式--“预设颜色”,使用时先在预设颜色中选中一种色彩,然后再画线,该线的颜色即为在预设颜色中选中的色彩。
系统支持键盘画线,十字游标状态下左右光标键、空格键移动定位点,按[回车]键设定定位点;
系统会自动保存用户的所有画线,下次进入该图时又会自动显现出来,所以,如果您是在一个不常用的指标图上画线,在退出前可以先选定画线工具里的“自动隐藏”键,在不打开画线工具的情况下,所画任何线都会自动隐藏,需要使用时打开画线工具即可,否则系统会一直保存直到您删除。对于您想长期保存某些画线可使用工具中的“另存为”键单独保留,以后使用时可从工具中的“打开文件”调用,同时可方便的通过“导入”“导出”画线文件,方便交流。

请高手写一个通达信的CCI加均线MA的公式

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
A:=CCI.CCI;
DRAWICON(CROSS(MA1,MA2) AND A<-100,MA1,1);
DRAWICON(CROSS(MA2,MA1) AND A>100,MA1,2);

公式已测试通过!
希望能够帮助你!

效果图如下:

求高手帮助写个 通达信 MA均线系统,连续n天向上公式。 如日线 ;120天(n天)均

A:=MA(C,120);

连续N天向上:BARSLAST(A<REF(A,1))>=N;

-----------------------------------------

求高手帮助写个 通达信 MA均线系统,连续n天向上公式。 如日线 ;120天(n天)均

-----注意:你要的N天的,也就是说N为多少得由你定

比如:N;=10;

N;=80;

N:=900;

这个天数由你自己定

------------------------------------------

在通达信软件, MA均线系统中,用选股器 如何选出 ;某条均线(此线是变数,可以是10天线 也可以是60天线,总之 1--1000天线可任选。)连续 n 个交易周期( 这 n 个周期也是变数, 总之 1--1000交易周期可任选  ) “上涨” 或 “下跌 ” (双向的)公式。

--------------------------------------------------

A:=MA(C,M);

走向:=IF(A<REF(A,1),1,2);

连续N天向:BARSLAST(走向=上或下)>=N;

参数和参数精灵就看图,自己填